https://www.ory.sh/ logo
#talk-kratos
Title
# talk-kratos
f

flat-rose-25983

04/04/2022, 10:59 AM
Hey guys ! I have configure google login on my Kratos config but it keeps on redirecting me on signUp after registering with google and cookie is not set. Here is my kratos config :
selfservice:
default_browser_return_url: <http://localhost:3000/>
whitelisted_return_urls:
- <http://localhost:4455>
methods:
password:
enabled: true
oidc:
enabled: true
config:
providers:
`- id: google # this is
<provider-id>
in the Authorization callback URL. DO NOT CHANGE IT ONCE SET!`
provider: google
client_id: XXXX
client_secret: XXXX
mapper_url: file:///etc/config/kratos/oidc.google.jsonnet
scope:
- email
- profile
requested_claims:
id_token:
email:
essential: true
email_verified:
essential: true
given_name:
essential: true
family_name: null
hd: null # If you want the G Suite domain
flows:
error:
ui_url: <http://localhost:4455/error>
settings:
ui_url: <http://localhost:4455/settings>
privileged_session_max_age: 15m
recovery:
enabled: true
ui_url: <http://localhost:4455/recovery>
verification:
enabled: true
ui_url: <http://localhost:4455/verification>"
after:
default_browser_return_url: <http://localhost:4455/auth/login?email-verification-status=true>
logout:
after:
default_browser_return_url: <http://localhost:4455/auth/login>
login:
ui_url: <http://localhost:4455/auth/login>
lifespan: 1h
after:
password:
hooks:
- hook: require_verified_address
registration:
lifespan: 1h
ui_url: <http://localhost:4455/auth/registration>
after:
oidc:
hooks:
- hook: session
d

damp-sunset-69236

04/05/2022, 7:20 AM
Hello. Consider using 127.0.0.1 for your case. AFAIK you can have issues with cookies for localhost domain using google chrome. At the first glance your configuration looks good
f

flat-rose-25983

04/05/2022, 10:06 AM
@User I was able to signUp and login with google but I have one weird issue.If I logout and click signUp with google the cookie get set with previous create account instead try to create new account.
8 Views