https://www.ory.sh/ logo
#talk-kratos
Title
# talk-kratos
e

enough-winter-51484

11/26/2021, 2:30 PM
I try to setup Kratos (with docker compose). Did make a Dockerfile, take the "oryd/kratos:v0.8.0-alpha.3" image, and copy a default config file to "/etc/config/kratos/config.yaml". I did set a ENV variable CONFIG with the same path. But it is not loading the config file. I looked into the docker image to look if the file is really there, and it was. Also the ENV variable was loaded into te container at runtime. Do I miss something (I use the ENV variable, and not use the --config parameter).
b

blue-state-12403

11/26/2021, 2:37 PM
Does this ENV var exist? I can not remember having seen it in the docs
e

enough-winter-51484

11/26/2021, 2:39 PM
It is documentated https://www.ory.sh/kratos/docs/reference/configuration If you search for "config:", then te last result.
b

blue-state-12403

11/26/2021, 2:40 PM
you are right
In case it helps: I have overwritten the "entrypoint" declaration to
sleep 9999999
and removed the
command
from my docker-compose, so kratos boots up and sleeps. I then connected to the container and tried
kratos serve
which fails with the same error, even tough
echo $CONFIG
sucessfully shows the content. i then tried
kratos serve --config $CONFIG
and this works flawlessly, so I guess the env var is simply not parsed.
e

enough-winter-51484

11/26/2021, 3:20 PM
Ah ok, thanks! Do you think it is needed to create a issue/bug on Github? I will continue with the parameter (for now) 🙂
b

blue-state-12403

11/26/2021, 3:21 PM
I have no idea