https://www.ory.sh/ logo
#talk-kratos
Title
# talk-kratos
f

faint-energy-48611

12/02/2021, 1:27 PM
After upgrade to kratos 0.8.0 I am unable to send mails through gmail SMTPS unless I set
disable_starttls=true
or set the protocol to SMTP... It's not safe to do, right? 😅 The error I see in courier logs is
first record does not look like a TLS handshake
. My connection_uri looks like this:
<smtps://email%40domain.com:password@smtp.gmail.com:587>
h

high-optician-2097

12/02/2021, 1:32 PM
Check the changelog - we documented what you need to do there
f

faint-energy-48611

12/02/2021, 1:42 PM
SMTP with implicit TLS variant doesn't work for me for some reason, so I guess my only option is to go with Starttls by changing protocol to smtp To whoever else it may concern, here's the release docs: https://github.com/ory/kratos/blob/master/CHANGELOG.md#breaking-changes Thanks @high-optician-2097
h

high-optician-2097

12/02/2021, 5:03 PM
my pleasure 🙂
2 Views