https://www.ory.sh/ logo
#talk-kratos
Title
# talk-kratos
t

thankful-secretary-66849

04/08/2022, 10:14 PM
sign in with apple seems to be not working with 0.9? It’s giving me invalid_client error after logging in to apple. Any idea why?
1
m

magnificent-energy-493

04/11/2022, 10:10 AM
Check out this PR: https://github.com/ory/kratos/pull/2331 We just need a test to get it merged basically, but I have not tried it out yet.
p

purple-apple-47041

05/03/2022, 7:42 PM
@User I am also getting this error. This is not related to the mapping of firstName and lastName. It seams something is improperly configured with apple sign in. I updated the attributes for team_id, private_key_id, and private_key to fit the new config. but I get the following error
Copy code
oauth2: cannot fetch token: 400
Response: {"error": "invalid_client"}
This did not happen on v0.8.2-alpha.1
m

magnificent-energy-493

05/03/2022, 10:06 PM
Could this be because the OpenId Connect config keys have been renamed? https://github.com/ory/kratos/blob/master/CHANGELOG.md#breaking-changes-2
The following OpenID Connect configuration keys have been renamed to better explain their purpose:
```- private_key_id
+ apple_private_key_id
- private_key
+ apple_private_key```
p

purple-apple-47041

05/03/2022, 11:24 PM
@User I did rename the keys, the containers failed to start with the old keys. I think for whatever reason there is an issue with the request to apple. I know the info is correct since it worked with the same oidc info prior to upgrading. I will keep looking into it and keep you updated if I resolve the issue but do you have any other ideas?
I also rolled back to 0.8 and it worked again after reverting my config modifications
m

magnificent-energy-493

05/04/2022, 7:05 AM
hm that was from the top of my head on Apple OIDC issues - I haven’t set it up myself, so hard to reproduce atm. But will see to make an effort to create an instance with all the OIDC providers to test such things. Please keep us updated and if you cant figure it out, feel free to open a bug report.
p

purple-apple-47041

05/12/2022, 5:49 PM
Thanks for responding @magnificent-energy-493. We still cannot figure out what is going on so we rolled back to 0.8 and everything is working. We will attempt to upgrade again in the near future but we are in a sprint lack the time to dig into this issue more. Once we do I will be in touch!
m

magnificent-energy-493

05/16/2022, 8:58 AM
Ok thanks Anthony. Some oher users I spoke to were able to resolve their problem, ususally it was some misconfiguration on the Apple OIDC side. But I guess you already made sure of that, so please be in touch if you run into it again 🙏
3 Views