Hi All, trying out Keto for the first time. Follo...
# talk-keto
Hi All, trying out Keto for the first time. Followed the install instructions and getting this error when running
keto help
. Anyone know what that is?
Copy code
➜  keto git:(0d1e33a) keto help
fatal error: unexpected signal during runtime execution
[signal SIGSEGV: segmentation violation code=0x1 addr=0xb01dfacedebac1e pc=0x7fff2053dc9e]

runtime stack:
runtime: unexpected return pc for runtime.sigpanic called from 0x7fff2053dc9e
stack: frame={sp:0x7ffeefbff548, fp:0x7ffeefbff598} stack=[0x7ffeefb805e8,0x7ffeefbff650)
0x00007ffeefbff448:  0x01007ffeefbff468  0x0000000000000004
0x00007ffeefbff458:  0x000000000000001f  0x00007fff2053dc9e
0x00007ffeefbff468:  0x0b01dfacedebac1e  0x0000000000000001
0x00007ffeefbff478:  0x0000000004035d51 <runtime.throw+0x0000000000000071>  0x00007ffeefbff518
0x00007ffeefbff488:  0x0000000004e74117  0x00007ffeefbff4d0
0x00007ffeefbff498:  0x0000000004036008 <runtime.fatalthrow.func1+0x0000000000000048>  0x000000000580bbc0
did you build keto yourself? I would suggest to use a precompiled binary from the releases https://github.com/ory/keto/releases/tag/v0.7.0-alpha.1
👍 1
update golang/x/sys to latest version it sresolves it
i tried installing via brew and then tried building myself and got the same error.
downloading the binary worked, thanks @User!
🎉 1
🔥 2
which one did you download and what architecture do you have? could be an apple arm issue with brew 🤔
@User I know this issue, you need to update golang/x/sys to latest
I tried that first @User and it didn’t seem to make a difference. Downloading the binary did work. @User I’m running an intel based Mac, so I downloaded the non ARM binary. https://github.com/ory/keto/releases/download/v0.7.0-alpha.1/keto_0.7.0-alpha.1_macos_64bit.tar.gz
maybe it was another dependency
but it was someting in golang/x